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Programming Tektronix OpenChoice Oscilloscopes  
with LabVIEW 

Introduction 
LabVIEW is a graphical development environment for acquiring, analyzing and 
presenting data. This makes it a good companion to your TDS OpenChoice 
oscilloscope with its own data acquisition and analysis abilities. 

Tektronix has worked with National Instruments to provide a LabVIEW add-on, 
which highlights some of the advantages of using LabVIEW with Tektronix 
OpenChoice Oscilloscopes. This add-on is preinstalled on each scope along with 
an evaluation version of LabVIEW. This add-on can also be used with a full 
development version of LabVIEW. 

The add-on consists of the following components: 

 A National Instruments book titled “Getting Started with LabVIEW and 
Tektronix Open Windows Oscilloscopes”. This article highlights some key 
contents of that book. 

 A Scope Analysis demo which demonstrates some of the analysis 
capabilities of LabVIEW working with Tektronix scopes 

 Several LabVIEW examples with full source code which show different 
programming techniques 

 Scope specific function palettes which are described in more detail later in 
this article 

Please refer to the installation instructions available on the LabVIEW add-on CD 
to determine the order in which the various components should be installed. 

You use LabVIEW to create virtual instruments, also known as VIs. A LabVIEW 
VI consists of a front panel and a block diagram. 

The front panel provides the user interface for your program. Use the front panel 
to input data and view outputs. Build the front panel with graphical 
representations of controls and indicators. A control could be a knob or a switch. 
An indicator could be a graticule on which to display oscilloscope-style 
waveforms. 
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The block diagram contains the VI’s underlying code. Build your block diagram 
with functions, other VIs and wires. The wires connect the block diagram objects 
to each other. You can draw upon LabVIEW’s libraries for data collection, 
analysis, presentation, and storage.  

To help you create and edit your program’s front panel and block diagram, 
LabVIEW provides palettes. These are shown in the table shown below. 
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Palette Appearance Description 
   
Tools 

 

Use this palette with both the front panel 
and the block diagram. The tools in this 
palette let you operate and modify the front 
panel and block diagram objects. To display 
this palette, go to the front panel or block 
diagram menu bar and click on: 
Windows -> Show Tools Palette 

   
Controls 

 

Use this palette with the front panel. It 
provides your front panel’s controls and 
indicators. To display this palette, go to the 
font panel menu bar and click on: 
Windows -> Show Controls Palette 

   
Functions 

 

Use this palette with the block diagram. It 
provides your block diagram’s functions and 
VIs. To display this palette, go to the block 
diagram menu bar and click on: 
Windows -> Show Functions Palette 

 

The functions palette includes oscilloscope-specific sub-palettes for each of the 
TDS5000, 6000, 7000, and 8000 series open Windows oscilloscopes. You can 
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use them to manage waveform transfer between your LabVIEW applications and 
your TDS open Windows oscilloscope. 

Programming Options  
You can use either VISA I/O functions or VXIplug&play instrument drivers to 
communicate with your oscilloscope.  

Advanced users can use VISA to send and receive text based messages to the 
oscilloscope directly. You may want to use this method if you need complete 
control of how the instrument is programmed. This method has a higher learning 
curve than using an instrument driver. However, there are some opportunities for 
optimization if you are familiar with the GPIB command set.  

Most users should use VXIplug&play driver to access all the scope functionality 
from LabVIEW. Tektronix has worked with National Instruments to provide 
LabVIEW wrappers that are customized for all Tektronix OpenChoice 
oscilloscopes. Note that the instrument drivers have to be installed after installing 
LabVIEW. These LabVIEW wrappers provide a convenient way of accessing the 
different functions in the driver. You can access these wrappers from the 
Functions->Instrument Drivers palette as show in the following illustration: 
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Another option is to use calls to VIs on the Functions->Tektronix palette. You 
can also mix calls to these VIs with calls to VISA and instrument drivers. 

These VIs communicate with the scope through the standard Tektronix 
VXIplug&play instrument drivers and simplify tasks, such as transferring 
waveforms, timing and scaling information to and from LabVIEW. 

The scope specific VIs simplify these tasks by grouping related operations. For 
example, The Simple Get Waveform VIs can acquire waveform signals from a 
live source such as a channel, reference or math source or from a file. This article 
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provides step by step instructions on building an example using these scope 
specific VIs. 

Another option for communicating with your instrument is to use ActiveX. You 
can work with TVC and IVI-COM drivers using the ActiveX support provided 
by LabVIEW. An article in the SDK (Using the TekScope IVI-COM Driver in 
LabVIEW) provides step by step instructions on how to set up a sample VI in 
LabVIEW using a Tektronix IVI-COM driver. Unlike the Plug and Play drivers, 
customized wrappers are not provided for Tektronix IVI-COM drivers. 

3. Scope Analysis Overview 

You can observe LabVIEW’s potential for problem solving by running the 
LabVIEW Scope Analysis Demo. 

This LabVIEW add-on for your open Windows oscilloscope provides 
acquisition, analysis, and presentation features. It runs independently of the 
LabVIEW development environment and does not require LabVIEW to be 
installed on your oscilloscope. 

To run, click on:  

Start->Programs->National Instruments->LabVIEW TDS#k Scope Demo-
>LabVIEW Scope Analysis Demo (TDS#k),  

where # represents the number of your open Windows oscilloscope series. 

The LabVIEW Scope Analysis Demo screen should appear, as shown to the 
rights. Check the Software Connection Name. The default value of 
GPIB8::1::INSTR applies to LabVIEW applications running on your open 
Windows oscilloscope. If you are running the demo from a computer connected 
to your oscilloscope remotely, you should consult with the TekVISA Resource 
Manager to locate the correct value for your oscilloscope. Use of this Resource 
Manager is documented elsewhere in your OpenChoice Software Development 
kit. 
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The LabVIEW Scope Analysis 
Demo screen should appear, as 
shown to the right. Check the 
Software Connection Name, The 
default value of GPIB8::1::INSTR 
applies to LabVIEW applications 
running on your open Windows 
oscilloscope. If you are running the 
demo from a computer connected 
to your oscilloscope remotely, you 
should consult with the TekVISA 
Resource Manager to locate the 
correct value for your oscilloscope. 
Use of this Resource Manager is 
documented elsewhere in your 
OpenChoice Software 
Development kit. 

 
  
Click on the Start Demo button to 
begin the application. A screen 
similar to the one to the right 
should appear. Use the Acquire, 
Analyze, and Present tabs at the 
bottom of the screen to peruse the 
various demo features. 

 
 

4. A Simple LabVIEW Demo 

The purpose of this demo is to familiarize you with creating a LabVIEW virtual 
instrument on your open Windows oscilloscope. The input is a simple probe 
compensation signal. The output is a graph of that signal. The demo assumes that 
you have an open Windows TDS5000, 6000, or 7000 series oscilloscope with 
LabVIEW installed on it, and a cable connecting your oscilloscope’s probe 
compensation signal to channel 1. Press the oscilloscope’s front-panel 
AUTOSET button to obtain a clear view of the probe compensation signal. 
Minimize the oscilloscope application. 

a. Start LabVIEW from Windows by clicking on: 
Start -> National Instruments -> LabVIEW 6.1 -> LabVIEW 
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You should see a LabVIEW 
window, as shown in the figure to 
the right 
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b. VI Creation 
 

Click the button labeled New VI. 
This brings up a blank front panel 
and a blank block diagram, as 
shown to the right. 
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c. Front Panel Creation 

Create your virtual instrument’s 
user interface. In this demo, you 
will do that by creating a front 
panel with an oscilloscope display 
on it. To do this, click, on the front 
panel’s menu bar, Window->Show 
Controls Palette, as shown to the 
right. 

 
  
This will bring up the Controls 
palette. 

 
  
Then select the Graph icon in the 
palette. This brings up the Graph 
sub-palette. 

 
  
Click on the Waveform Graph 
control from the sub-palette. Then 
click on the front panel to place the 
Waveform Graph on the front 
panel, as shown to the right. 

 
  

Move the indicator in your front panel as desired. To do that, bring up the Positioning tool . Do 
this by selecting Show Tools Palette from the Window pull-down menu on the front panel window. 
Click on the positioning icon in that palette. 
  
Use the positioning cursor to position the Waveform Graph as you want on the front panel 
window. 
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d. Block Diagram Creation 

Create your instruments underlying code by developing the block diagram. On 
the Block Diagram window’s menu bar, click on Window->Show Functions 
Palette to bring up the Functions palette. Then click on the Tektronix item in 
the palette to bring up the Tektronix palette. It should contain an icon for your 
series of TDS open Windows oscilloscope. 

 

Put the VIs for the oscilloscope functions you want to use on your block diagram. 
Do this by clicking on each of the Initialize, Simple Get Waveform, and Close 
functions in the Tektronix Functions palette and then clicking on your block 
diagram, as shown in the figure below. 
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If you want, you can further position the function blocks with the position tool 
from the Tools palette. 

e. Set Values 

Now define a constant of a function to set. Do this by first selecting the Wiring 
tool from the Tools palette. Then move it to the input (left side) of the Initialize 
VI labeled reset device. Right-click your mouse and select Create-Constant 
from the resulting menu, as shown below. 

  
Now set the value of that constant. Do this by selecting the Operating tool from 
the Tools palette. 
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Then click on the reset device constant. Set the value to F, for false. 

Now, set another value. Once again select the Wiring tool from the Tools 
palette. Then right-click the VISA resource name input on the left side of the 
Initialize VI. Select Create-Constant from the menu. If GPIB8::1::INSTR 
does not appear, check that your TekScope application is running. 

You have now added all the VIs (objects) on your block diagram needed to 
process the data. 

f. Wiring the VI 
The next step is to enable the VIs on your block diagram to communicate with 
each other. To do this, use the Wiring tool from the Tools palette. 

 

Select the Wiring tool. Wire the following connections: 

1. Connect the Instrument Handle Out terminal of the Initialize VI to the 
Instrument Handle In terminal of the Get Waveform VI. 

2. Connect the Waveform output terminal of the Get Waveform VI to the 
Waveform Graph indicator terminal.  

3. Connect the Instrument Handle Out terminal of the Get Waveform VI 
to the Instrument Handle terminal of the Close VI. 

g. Running the VI 

The last step is to start the program running. To do this, simply click on the Run 
button.  

 
In this demo, a waveform should 
then appear on the front panel 
waveform indicator, as shown to 
the right. 
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More Scope-Specific Examples 

To see more examples of LabVIEW used with your open Windows oscilloscope, 
call up the Scope Example Browser.  

To call up the Scope Example 
Browser, click on the Help menu 
item in your front panel or block 
diagram. Then select Scope 
Example Browser, as shown 
below. 

 
  
The Scope Example Browser 
should appear, as shown to the 
right. Select an example of interest 
from the list. If desired, click on the 
Acquisition, Analysis, Scope 
Tools, or Applications tabs to find 
added examples. View them by 
clicking on the Open Example 
button. 

 
  
 

The examples in the Scope Example browser illustrate a wide range of LabVIEW 
programming techniques. The Acquisition section shows different examples for 
getting and storing waveforms from the scope. It includes VXIplug&play driver 
examples as well as VISA examples. The last example (Efficient VISA MultAcq) 
shows how you can optimize waveform transfer programming directly with 
VISA. 

The Analysis Section contains several examples, which highlight LabVIEW’s 
analysis capability. Example include IIR filters, FFT, Tone detection, Total 
Harmonic Distortion, Averaged DC-RMS etc. You can use this example as a 
starting point and substitute your own analysis function. 

The Scope Tool section contains several examples for controlling and 
manipulating scope parameters and features. 

Finally, the Applications section contains different utilities for working with 
scopes including the ability to generate HTML reports, a soft front panel which 
provides the capability to control basic scope parameters, a setup sequencer 
which allows you to go through a sequence of setups and store the resulting 
waveforms and measurements in a report.  


