Difference between revisions of "Starting CODA for shift workers"

From Hall A Wiki
Jump to: navigation, search
 
(9 intermediate revisions by the same user not shown)
Line 1: Line 1:
*DAQ should be running on hadesk4 in a VNC
+
https://hallaweb.jlab.org/wiki/index.php/BigBite_trigger_and_DAQ
 +
 
 +
*DAQ should be running already on hadesk4 in a VNC
  
 
*If the VNC is not opened, or after logging in as adaq
 
*If the VNC is not opened, or after logging in as adaq
  type : RunCoda
+
**type : RunCoda VNC password is adaq password, alternatively connect on vnc on adaq2:4
 
+
  VNC password is adaq password
+
 
+
alternatively connect on vnc on adaq2:4
+
  
 
*Use CODA scripts buttons on first Desktop to start the ROC Xterms and Run Control
 
*Use CODA scripts buttons on first Desktop to start the ROC Xterms and Run Control
  
*If needed use Rstart CODA components
+
*If needed use Restart CODA components
  
*In runcontrol make sure sbsts session is chosen and config GMN1nosbsvme20 is choosen
+
*In runcontrol make sure sbsts session and config GMN1 are chosen
  
 
*To start a run
 
*To start a run
  
 
**hit configure button in runcontrol, might need to hit it twice if vtpROC20 misses the first configuration
 
**hit configure button in runcontrol, might need to hit it twice if vtpROC20 misses the first configuration
**hit download button
+
**hit download button ( wait until vtpROC20 is done )
 
**check prescale factors ( To open prescale gui : ssh to sbs-onl@adaq2 and type prescale )
 
**check prescale factors ( To open prescale gui : ssh to sbs-onl@adaq2 and type prescale )
 
**hit Start Run button
 
**hit Start Run button
 
**fill in run information in pop up box ( make sure you have correct target / runtype )
 
**fill in run information in pop up box ( make sure you have correct target / runtype )
 +
 +
*Pedestal run
 +
**select GM1_pedestal config
 +
**start run
 +
**stop run after at least 30 k events
 +
**go back to GMN1 configuration and start regular rub
 +
 +
*Troubleshooting
 +
**ER1 getting stuck at prestart
 +
***hit reset in runcontrol
 +
***hit configure, download, prestart and start a run
 +
 +
 +
**SEB and ER stuck at end of run
 +
***hit reset in runcontrol
 +
***hit restart CODA components
 +
***redo configure and download
 +
***start a run
 +
**GEM module not initializing or getting Errors
 +
***Reboot VTP crate : open in browser http://hallavme12.jlab.org
 +
 +
More on GEMs in https://hallaweb.jlab.org/wiki/images/1/12/GEM_operations.pdf
 +
 +
* All remote switches at https://hallaweb.jlab.org/wiki/index.php/Crate_resets
 +
 +
* rcgui not appearing
 +
 +
platform migth need to be restarted
 +
  ssh adaq@adaq2
 +
  sudo systemctl restart platform.service
 +
  use the killall xterm button and restart all terminals with Start Xterms
 +
  start run
 +
 +
 +
*if you are stuck check contact expert on slack ( in 4th desktop web browser ) or call DAQ on call ( number on slack channel on-call or on whiteboard)

Latest revision as of 12:20, 14 November 2021

https://hallaweb.jlab.org/wiki/index.php/BigBite_trigger_and_DAQ

  • DAQ should be running already on hadesk4 in a VNC
  • If the VNC is not opened, or after logging in as adaq
    • type : RunCoda VNC password is adaq password, alternatively connect on vnc on adaq2:4
  • Use CODA scripts buttons on first Desktop to start the ROC Xterms and Run Control
  • If needed use Restart CODA components
  • In runcontrol make sure sbsts session and config GMN1 are chosen
  • To start a run
    • hit configure button in runcontrol, might need to hit it twice if vtpROC20 misses the first configuration
    • hit download button ( wait until vtpROC20 is done )
    • check prescale factors ( To open prescale gui : ssh to sbs-onl@adaq2 and type prescale )
    • hit Start Run button
    • fill in run information in pop up box ( make sure you have correct target / runtype )
  • Pedestal run
    • select GM1_pedestal config
    • start run
    • stop run after at least 30 k events
    • go back to GMN1 configuration and start regular rub
  • Troubleshooting
    • ER1 getting stuck at prestart
      • hit reset in runcontrol
      • hit configure, download, prestart and start a run


    • SEB and ER stuck at end of run
      • hit reset in runcontrol
      • hit restart CODA components
      • redo configure and download
      • start a run
    • GEM module not initializing or getting Errors

More on GEMs in https://hallaweb.jlab.org/wiki/images/1/12/GEM_operations.pdf

  • rcgui not appearing

platform migth need to be restarted

 ssh adaq@adaq2
 sudo systemctl restart platform.service
 use the killall xterm button and restart all terminals with Start Xterms
 start run


  • if you are stuck check contact expert on slack ( in 4th desktop web browser ) or call DAQ on call ( number on slack channel on-call or on whiteboard)